Issues with network routing for Mac jobs

Incident Report for CircleCI

Monitoring

We've identified the issue. Some customers may experience jobs that hang or fail to progress during Github fetch steps due to intermittent networking issues. Our engineers are actively monitoring.

In the meantime, we've seen success with increasing the no_output_timeout to 15 - 20 min to allow more time for Github fetches. This can be done by following this community guide: https://support.circleci.com/hc/en-us/articles/360007188574-Build-has-Hit-Timeout-Limit
Posted Jul 13, 2026 - 23:35 UTC

Update

We've been able to reproduce the issue, but it still appears to be very much intermittent. We're continuing to work with our Mac infrastructure provider to help diagnose the issue. We'll update again soon.
Posted Jul 13, 2026 - 23:13 UTC

Update

We're still investigating these intermittent network issues. We'll update again shortly, we appreciate your patience.
Posted Jul 13, 2026 - 22:21 UTC

Investigating

We're received some reports of intermittent network issues between our mac infrastructure and a VCS provider again. We are investigating and will provide updates.
Posted Jul 13, 2026 - 21:52 UTC
This incident affects: macOS Jobs.