We are concluding this incident based on a confirmed fix with our infrastructure provider and successful tests. For any customers seeing failed runs, please run again for a successful connection.
Posted Jun 25, 2026 - 03:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2026 - 02:58 UTC
Investigating
Due to continued reports of intermittent failures and a lack of sustained improvement while in monitoring status, this incident is elevated back to investigating to escalate with our infrastructure provider.
Posted Jun 25, 2026 - 02:54 UTC
Update
We are continuing to monitor. We still observe a low percentage of intermittent failures. The failure rate is trending down as we continue to monitor. We advise customers to contact CircleCI Support if they see a change in degraded services and increased failure rate.
Posted Jun 25, 2026 - 02:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 25, 2026 - 01:22 UTC
Monitoring
Our team is moving this incident to Monitoring status based on significant improvement seen in our tests and low error rate. We are seeing improvement in network routing for Mac jobs and are actively engaged with our infrastructure provider. If your Mac jobs experience network-related failures or degraded service please reach out to CircleCI support.
Posted Jun 25, 2026 - 01:13 UTC
Update
We are seeing improvement in Mac job network routing.
We will continue to monitor for signs of recovery.
Posted Jun 25, 2026 - 00:39 UTC
Update
Mac jobs are still seeing intermittent failures with network routing.
We are working with our infrastructure provider to address the networking issues.
Posted Jun 24, 2026 - 23:56 UTC
Identified
We have implemented a change to address the routing issues and are monitoring the results.
Posted Jun 24, 2026 - 23:33 UTC
Investigating
What's happening Our engineers are investigating network routing issues for some Mac jobs.
What's impacted Mac jobs that make outbound requests, including checking out from GitHub.