Issues with network routing for Mac jobs

Incident Report for CircleCI

Resolved

We've confirmed the fix with our infrastructure provider and successful tests on our end. If customers continue to see any failed runs, please run again for a successful connection and reach out to Support if any further issues.
Posted Jul 13, 2026 - 19:40 UTC

Monitoring

Our Mac infrastructure provider has implemented a fix, we're starting to see recovery. We're monitoring and we'll update again shortly.
Posted Jul 13, 2026 - 19:29 UTC

Identified

We're working with our Mac infrastructure provider to attempt a mitigation. Will update again shortly.
Posted Jul 13, 2026 - 19:11 UTC

Investigating

We've received reports of intermittent network issues between our mac infrastructure and a VCS provider. We are investigating and will provide updates.
Posted Jul 13, 2026 - 18:55 UTC
This incident affected: macOS Jobs.