Errors with GitHub APIs delaying workflows

Incident Report for CircleCI

Resolved

GitHub API error rates have recovered to normal levels.

During the incident, some customers may have seen pipelines fail to start or not receive status updates. Some pipelines may be stuck in a running state.

* You should re-push commits or use the UI to manually trigger pipelines that didn't start.
* Pipelines in a stuck running state should be canceled and rerun.

If you encounter any issues please contact CircleCI support.
Posted Jul 20, 2026 - 01:45 UTC

Monitoring

We are seeing signs of recovery from the GitHub API.

We will stay in a monitoring state to verify that the API error rate has recovered.
Posted Jul 20, 2026 - 01:36 UTC

Update

We are also seeing errors processing push event webhooks due to the upstream API outage.

Users may need to retry pipelines for these push events.
Posted Jul 20, 2026 - 01:24 UTC

Identified

We have identified an issue with GitHub API requests that may cause some customers to see workflows stuck in a running state or workflows fail to start.

GitHub has reported incidents on the APIs

https://www.githubstatus.com/incidents/ph5nns5y4gxj
https://www.githubstatus.com/incidents/8vfyvq16hzh9

We are monitoring the stability of GitHub APIs and will update this page as more information is available.
Posted Jul 20, 2026 - 00:35 UTC
This incident affected: Pipelines & Workflows and Upstream Services (GitHub Git Operations, GitHub API Requests).