Pipelines page not loading

Incident Report for CircleCI

Resolved

This incident has been resolved. Things should be back to normal.
Posted Dec 03, 2025 - 15:30 UTC

Identified

We are seeing some issues loading the pipelines page. This is intermittent and won't affect most users. No work is being affected, just the display of pipelines. We have identified the issue and are working on a fix.
Posted Dec 03, 2025 - 13:37 UTC
This incident affected: CircleCI UI.