We have completed the kernel upgrades across all of the infrastructure used to run Docker jobs. Our monitoring shows Docker job execution is working as normal.
During the maintenance, a small number of running jobs were canceled as machines were upgraded. These jobs will have an "Infrastructure Fail" status in the CircleCI UI. You can rerun Infrastructure Fail jobs from the UI or pushing to your VCS brach.
Please contact CircleCI support if you have any additional questions or have problems running Docker jobs.
Thank you for your patience during this maintenance.
Posted Jul 10, 2026 - 05:03 UTC
Update
We have completed migrations on several clusters. Docker jobs are continuing to run as normal with minimal disruption.
Our team will continue to monitor the rollout and update on status as the remaining clusters are upgraded.
Posted Jul 10, 2026 - 02:25 UTC
Update
The rolling upgrade is proceeding across all clusters. Our team is continuing to monitor for delays and job failures.
Posted Jul 10, 2026 - 00:29 UTC
Update
The rolling upgrades are continuing on multiple clusters. We are observing minimal impact for Docker jobs.
Posted Jul 09, 2026 - 23:02 UTC
In progress
We have rolled out kernel upgrades to a portion of our fleet.
We are seeing positive results and are proceeding with additional clusters.
Posted Jul 09, 2026 - 21:59 UTC
Scheduled
What's Happening In order to address a High Severity CVE (CVE-2026-43499), we are rolling out an emergency security update across the entire CircleCI infrastructure used to run Docker jobs. To minimize customer impact, we are executing a rolling upgrade across each individual cluster one by one. We expect the entire update process to complete in approximately 8 hours, and we will provide updates as individual clusters are updated.
What's Impacted Customers running Docker jobs
What You Can Expect Customers may see brief interruptions to Docker jobs while the updated capacity is deployed. No action is required.
Thank you for your patience while our engineers complete the rollout.
We will provide further updates as the maintenance proceeds.