Upstream Issues With GitHub Causing Slow Checkout/Cloning Steps
Incident Report for CircleCI
Resolved
We have been monitoring the situation today and have not observed any abnormalities. However, if you continue to experience issues with upstream services, such as slow checkout or cloning of GitHub repositories, please do not hesitate to contact our support team.
Posted May 20, 2024 - 22:29 UTC
Monitoring
Our system is working as expected for now. Due to the sporadic nature of this issue, we will continue to monitor the situation until the upstream issues are fully resolved
Posted May 19, 2024 - 19:28 UTC
Identified
We have received reports of slow checkout/clones of repositories from GitHub. This is not impacting all checkouts and the operations eventually succeed.
Posted May 19, 2024 - 16:16 UTC
This incident affected: Upstream Services (GitHub).