Some Windows executors pinning to `current` are failing.
Incident Report for CircleCI
Resolved
We have identified that the failing images were pushed at 2023-02-22 00:20 UTC and the fixed image was published at 2023-02-22 10:26 UTC. Any builds with the affected image tags between these timestamps may remain in a stalled state. Users will need to cancel and re-run these jobs if required.

The incident is now resolved.
Posted Feb 22, 2023 - 10:42 UTC
Monitoring
We have implemented a fix and builds are now running as normal. We are continuing to monitor the status.
Posted Feb 22, 2023 - 10:34 UTC
Identified
An issue with the Windows `windows-server-2022-gui:current` and `2023.02.1` tags are causing builds to stall on `Preparing environment` step. This will also impact those using the Windows orb with `server-2022` and `default` executors. We have identified the issue and are working on a fix.
Posted Feb 22, 2023 - 10:24 UTC
This incident affected: Windows Jobs.