Insights service data is lagging

Incident Report for CircleCI

Resolved

The upstream issue has been resolved, and the insights data from the last 24 hours has caught up. Thank you for your patience.
Posted Aug 05, 2026 - 21:01 UTC

Identified

We have identified the issue, and are working with our upstream provider to resolve it now.
Posted Aug 05, 2026 - 18:25 UTC

Update

We are continuing to investigate and will update as we know more.
Posted Aug 05, 2026 - 17:46 UTC

Investigating

We are seeing an issue with Insights service where the data from the last 24 hours is lagging. We are investigating.
Posted Aug 05, 2026 - 16:58 UTC
This incident affected: CircleCI Insights.