CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

GitHub Webhooks and API degraded

Incident Report for CircleCI

Resolved

GitHub Webhooks and API processing has returned to normal.
Posted Feb 25, 2020 - 19:56 UTC

Update

GitHub checks posting is no longer delayed. Some checks have been lost as a result of the GitHub outage.
Posted Feb 25, 2020 - 19:28 UTC

Update

Checks are still delayed, GitHub are rate-limiting us so we can't churn through the queue as fast as we want.
Posted Feb 25, 2020 - 19:08 UTC

Update

Monitoring GitHub recovery, checks still delayed.
Posted Feb 25, 2020 - 18:40 UTC

Update

GitHub-related actions may be impacted due to GitHub API delays, such as adding projects.
Posted Feb 25, 2020 - 18:15 UTC

Update

GitHub-related actions may be impacted due to GitHub API delays, such as adding projects.
Posted Feb 25, 2020 - 17:50 UTC

Update

We are continuing to monitor. Repository related API calls are delayed, workflows and webhooks are returning to normal.
Posted Feb 25, 2020 - 17:19 UTC

Monitoring

Workflows and GitHub Checks are delayed.
Posted Feb 25, 2020 - 16:50 UTC
This incident affected: Upstream Services (GitHub API Requests).