Usage API Data Unavailable for December 11, 2025

Incident Report for CircleCI

Resolved

The Usage API issue has been resolved. Data is loaded for yesterday 12/11. Thank you for your patience.
Posted Dec 12, 2025 - 19:07 UTC

Identified

The issue has been identified. Expected time to resolution: 90 minutes
Posted Dec 12, 2025 - 17:49 UTC

Investigating

We are currently investigating an issue affecting Usage API data availability for December 11, 2025. Customers querying usage data for this date will not receive results at this time. Usage data prior to December 11 remains accessible and unaffected.

This issue is isolated to data retrieval for the specified date. All other CircleCI functionality, including job execution and workflow triggering, continues to operate normally.

We are actively investigating the cause and will provide our next update within 30 minutes or as we know more.
Posted Dec 12, 2025 - 17:22 UTC
This incident affected: CircleCI Insights.