Mac jobs failing to start

Incident Report for CircleCI

Resolved

All Mac jobs are running successfully.

Our infrastructure provider has confirmed that the DDoS attack has been mitigated and that services have been restored.

Thank you for your patience during this incident.
Posted Jun 01, 2026 - 03:26 UTC

Update

Mac jobs are running successfully, and we are continuing to monitor the performance of our Mac fleet.

Thank you for your patience.
Posted Jun 01, 2026 - 02:05 UTC

Monitoring

We are seeing Mac jobs starting successfully and improved network connectivity to the Mac fleet, however our infrastructure provider is continuing to experience a DDoS attack.

We will continue to monitor the recovery while bringing additional capacity to our platform.
Posted Jun 01, 2026 - 01:36 UTC

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 01:05 UTC

Investigating

Mac jobs are continuing to experience failures. Our infrastructure provider is continuing to report that they are experiencing a DDoS attack causing high network latency and packet loss for our Mac fleet. We are working to bring up additional capacity to restore service.
Posted Jun 01, 2026 - 01:04 UTC
This incident affected: macOS Jobs.