All Docker Jobs are Seeing Long Queue Times
Incident Report for CircleCI
Resolved
This incident has been resolved.
Posted Nov 02, 2022 - 19:53 UTC
Update
While we added additional capacity, some customers may have experienced a “No space left on device” error. We have identified and resolved this issue and subsequent builds should succeed. We would like to thank you for your patience.
Posted Nov 02, 2022 - 19:19 UTC
Monitoring
We have added additional capacity and are seeing docker job queue times return to an expected range. We will continue to monitor the situation
Posted Nov 02, 2022 - 18:09 UTC
Update
At this time jobs running on docker executors are seeing average delays of around 50 seconds, however jobs on the xlarge resource class are seeing delays of about 4 minutes. We are working on adding additional capacity and will continue to add more until we return to expected docker job queue times
Posted Nov 02, 2022 - 18:00 UTC
Identified
Jobs running on docker executors are currently seeing delays of up to 1 minute in starting due to capacity issues with one of our cloud providers. We have escalated this to them and are working together toward a solution
Posted Nov 02, 2022 - 17:27 UTC
Investigating
Starting at 15:14 UTC, we are seeing a long queue time for docker jobs that use the x.large resource class. We are investigating the cause of this issue.
Posted Nov 02, 2022 - 17:05 UTC
This incident affected: Docker Jobs and CircleCI Dependencies (AWS).