Between 13:29 UTC and 18:20 UTC on June 9, 2026, some customers experienced 500 errors when making requests to the pipeline values and workflow API endpoints, as well as errors in the UI. Jobs running were not impacted during this window. The issue has been resolved and all affected functionality has returned to normal. We thank you for your patience while our team worked on implementing a fix.
Posted Jun 09, 2026 - 18:43 UTC
Monitoring
A fix has been deployed for the 500 errors customers were experiencing on the pipeline values and workflow API endpoints and in the UI. Engineers are monitoring the change. Jobs running are not impacted
Posted Jun 09, 2026 - 18:32 UTC
Update
Our engineers are continuing to investigate the 500 errors customers are experiencing on the pipeline values and workflow API endpoints, as well as errors in the UI. Jobs currently running are not impacted.
Posted Jun 09, 2026 - 18:20 UTC
Investigating
Some customers are experiencing 500 errors when making requests to the pipeline values and workflow API endpoints, as well as errors in the UI.
Engineers are actively investigating.
Posted Jun 09, 2026 - 17:45 UTC
This incident affected: CircleCI API and CircleCI UI.