Slow Docker operations to various registries (Dockerhub, ECR and quay.io)

Incident Report for CircleCI

Resolved

We are no longer seeing occurrences of this issue.
Posted Jun 30, 2020 - 14:49 UTC

Update

We are continuing to monitor for any further occurrences.

Please contact CircleCI Support if you are experiencing slow Docker operations.
Posted Jun 30, 2020 - 13:29 UTC

Monitoring

We are no longer seeing occurrences of this issue.

We will continue monitoring.
Posted Jun 30, 2020 - 13:29 UTC

Update

Our investigation is still ongoing. Please contact CircleCI Support if your builds are affected.
Posted Jun 30, 2020 - 12:58 UTC

Update

We are liaising with GCP and continuing to investigate this issue.
Posted Jun 30, 2020 - 12:17 UTC

Update

We are still investigating this issue that is causing slow network traffic and increases in connection failures.
Posted Jun 30, 2020 - 11:18 UTC

Investigating

We are seeing a longer duration for Docker image downloads which is causing an increase in builds duration.

The issue is intermittent and is affecting Remote Docker and Machine jobs.

We are currently investigating this issue.
Posted Jun 30, 2020 - 10:45 UTC
This incident affected: Docker Jobs and Machine Jobs.