Mac jobs failing to start

Incident Report for CircleCI

Update

Mac jobs are continuing to experience failures. Our infrastructure provider is reporting they are experiencing a DDoS attack causing high network latency and packet loss for our Mac fleet. We are working to bring up additional capacity to restore service.

We will continue to update as more information is available.
Posted May 31, 2026 - 22:38 UTC

Update

We are continuing to investigate failures with Mac jobs starting due to high network latency and packet loss. Our engineers remain engaged with our infrastructure provider to restore service.

We will provide another update within the hour, or sooner if circumstances change. We thank you for your patience while our engineers work to resolve this.
Posted May 31, 2026 - 21:24 UTC

Update

We are still seeing failures with Mac jobs starting due to high network latency and packet loss. We will continue to update as we have more information on a resolution.
Posted May 31, 2026 - 20:05 UTC

Update

We are continuing to work on resolving the networking issue for Mac jobs.
Posted May 31, 2026 - 19:09 UTC

Identified

We have identified a network outage that is preventing Mac jobs from starting. This include m4pro.medium and m4pro.large resource types.

We are working with our infrastructure provider to restore service.

We will update this incident as we work to resolve the issue.
Posted May 31, 2026 - 18:15 UTC
This incident affects: macOS Jobs.