Dropped webhooks for GitHub pipelines

Incident Report for CircleCI

Resolved

GitHub have updated their API status to operational, and we are no longer seeing related customer impact.
Customers will need to push new commits for any lost pipelines.
Posted May 26, 2025 - 10:11 UTC

Monitoring

Some GitHub webhooks are being dropped due to an incident with GitHub.
Customers may also experience a delay in scheduled workflows.
Posted May 26, 2025 - 08:56 UTC
This incident affected: Upstream Services (GitHub Webhooks).