Elevated 429 errors pulling from maven central

Incident Report for CircleCI

Resolved

Customers running jobs that pulled dependencies from Maven Central experienced elevated 429 (rate limit) errors. We have worked with Sonatype to allow list CircleCI's dedicated IP ranges. Customers using our IP ranges feature should no longer see Maven Central rate limits affect their jobs while we continue work to fully address the issue for all customers.

Customers whose jobs failed during this window may rerun affected jobs. We thank you for your patience while our team worked on implementing a fix.
Posted May 14, 2026 - 19:38 UTC

Monitoring

We're monitoring to verify that rate limited jobs are recovering.
Posted May 14, 2026 - 18:08 UTC

Investigating

Jobs pulling dependencies from maven central are experiencing increased 429 errors due to maven central rate limits.

We are investigating the issue and working to identify mitigations for customer jobs.
Posted May 14, 2026 - 16:49 UTC
This incident affected: Docker Jobs, Machine Jobs, and macOS Jobs.