CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

GitHub service degradation may impact customers using GitHub

Incident Report for CircleCI

Resolved

The issue impacting customers who use GitHub as their VCS while GitHub was undergoing a service degradation (https://www.githubstatus.com/incidents/yjysg0xrl67m) has now been resolved. GitHub has resolved the underlying issue and the affected functionality has returned to normal.

We thank you for your patience.
Posted Jul 24, 2026 - 17:41 UTC

Identified

GitHub is currently experiencing a service degradation (https://www.githubstatus.com/incidents/yjysg0xrl67m). Customers who use GitHub as their VCS may experience impact to their CircleCI platform experience as a result, impacting checkout and workflows.

We will provide another update as we have more information to share. Thank you for your patience.
Posted Jul 24, 2026 - 16:35 UTC
This incident affected: Pipelines & Workflows.