Job start times for m1.medium, m2pro.medium, and m2pro.large are elevated

Incident Report for CircleCI

Resolved

The issue impacting queue times for Mac M1 medium and large jobs has now been resolved. Mac M4 Pro resources remain available with additional capacity.
Thank you for your patience while our engineers worked to resolve this issue.
Posted Sep 08, 2025 - 19:14 UTC

Monitoring

Mac M1 medium and large jobs are now starting normally—delays have been resolved and queue times have returned to standard levels.

Please note that demand remains high for M2 Pro large and medium resource classes. For teams needing immediate capacity, Mac M4 Pro resources are currently available. You can find more information about available resource classes at https://circleci.com/docs/using-macos/#available-resource-classes.

If you have any questions or need assistance, please contact our customer support team. Thank you for your patience during this period.
Posted Sep 08, 2025 - 18:19 UTC

Identified

Task start times for m1.medium, m2pro.medium, and m2pro.large are elevated and you may experience queueing.
Posted Sep 08, 2025 - 15:54 UTC
This incident affected: macOS Jobs.