Increased Job Queue Times: Windows, Android, and GPU

Incident Report for CircleCI

Update

Queue times for both Android and Windows jobs continue to be volatile, with sharp swings up and down. This remains related to capacity constraints with our third-party infrastructure provider. Our team will continue to monitor and provide updates at least every 30 minutes. We appreciate your patience.
Posted Aug 04, 2026 - 21:46 UTC

Update

Queue times for both Android and Windows jobs, which had been recovering, have started to rise again. This continues to be related to capacity constraints with our third-party infrastructure provider. We'll continue to monitor and provide updates at least every 30 minutes. We appreciate your patience.
Posted Aug 04, 2026 - 21:16 UTC

Update

Queue times continue to gradually recover with our third-party infrastructure provider, though we've seen a slight uptick in the last 30 mins. We're keeping an eye on this and will keep you updated as things get back to normal. Again, thank you for your patience.
Posted Aug 04, 2026 - 20:33 UTC

Monitoring

We're starting to see queue times slowly recovering. We'll be monitoring this situation, we appreciate your patience.
Posted Aug 04, 2026 - 19:59 UTC

Investigating

We are experiencing increased queue times for Windows, Android, and GPU jobs due to capacity constraints with a third-party infrastructure provider. Jobs will continue to be processed but may take longer than usual to start. Thank you for your patience while our engineers work to resolve this.
Posted Aug 04, 2026 - 19:27 UTC
This incident affects: Machine Jobs and Windows Jobs.