Higher wait times for Linux, Remote Docker and Mac resource classes

Incident Report for CircleCI

Resolved

This incident has been resolved and wait times have returned to normal. We appreciate your patience.
Posted Dec 16, 2025 - 22:12 UTC

Monitoring

Wait times for Linux, Remote Docker and Mac are starting to return to normal. We're going to keep our eye on things for just a bit longer and will update again shortly.
Posted Dec 16, 2025 - 22:00 UTC

Identified

We've ID'd the problem and we're rolling out a fix.
Posted Dec 16, 2025 - 21:49 UTC

Investigating

Customers using Machine, Linux Remote Docker, and Mac resource classes may be experiencing elevated wait times when starting jobs. We're investigating and will update again soon.
Posted Dec 16, 2025 - 21:17 UTC
This incident affected: Machine Jobs and macOS Jobs.