Delay in Usage API Data

Incident Report for CircleCI

Resolved

The incident has been resolved. We appreciate your patience. We will continue to monitor throughout the weekend.
Posted Oct 10, 2025 - 23:25 UTC

Update

Recovery is ongoing. Apologies for the delay. We will provide updates as we get them. Timing remains tbd.
Posted Oct 10, 2025 - 21:05 UTC

Monitoring

Recovery in progress. Currently monitoring.
Posted Oct 10, 2025 - 19:21 UTC

Update

We traced the issue to a vendor and have reached out to them. As such, time to resolution remains unknown. Note: this does not affect historical data, just data for yesterday, October 9th.
Posted Oct 10, 2025 - 17:36 UTC

Identified

An issue has been identified causing a delay in available usage API data.
Customers may experience issues retrieving usage reports for recent timeframes.
Posted Oct 10, 2025 - 14:34 UTC
This incident affected: CircleCI API.