Incident with GitHub APIs

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 16:41 UTC

Monitoring

We are seeing signs of recovery from the GitHub API.
Posted Jun 10, 2026 - 16:32 UTC

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 16:30 UTC

Investigating

Some users may have seen delays or missing commit statuses on GitHub PRs due to an ongoing GitHub API incident.

We are continuing to process builds as normal.

We will provide further updates as we get more information
Posted Jun 10, 2026 - 16:30 UTC
This incident affected: Upstream Services (GitHub API Requests).