Delays in starting jobs using the gen3 resource class

Incident Report for CircleCI

Update

We are continuing to investigate elevated wait times affecting customers using gen3 machine executors. Affected jobs may take longer than usual to start. We will provide another update as soon as we have more information to share.
Posted Jul 22, 2026 - 20:43 UTC

Investigating

We are investigating delays in starting jobs using the gen3 resource class.
Posted Jul 22, 2026 - 19:57 UTC
This incident affects: Machine Jobs.