Delayed start and/or not running macOS jobs
Incident Report for CircleCI
Resolved
Our systems have recovered and macOS jobs are processing normally now. This incident is now resolved.
Posted May 05, 2021 - 20:19 UTC
Update
We are continuing to monitor our fix for the macOS executor. Our systems are working through a backlog of queued macOS jobs. At this stage, we are downgrading the incident to Minor as our systems continue to recover. macOS jobs will continue to run.
Posted May 05, 2021 - 19:03 UTC
Monitoring
We have fully identified the cause of the delays in macOS jobs starting and we are currently monitoring our deployed fix. To avoid impact in delays of macOS jobs starting, include a `brew update` step in your job OR a fresh install of brew.
Posted May 05, 2021 - 18:47 UTC
Update
Our investigation is continuing to determine the exact cause of delayed starts for macOS.
Posted May 05, 2021 - 17:49 UTC
Update
We believe we have identified the cause and are completing tests to confirm, we will share another update shortly.
Posted May 05, 2021 - 17:30 UTC
Update
We are continuing to investigate the cause of the delayed start of macOS jobs and will share an update as soon as we have more information.
Posted May 05, 2021 - 17:11 UTC
Investigating
Some customers are experiencing a delayed start in macOS jobs or jobs are not running at all. We are currently investigating the cause and will update by 5:10 PM UTC.
Posted May 05, 2021 - 16:50 UTC
This incident affected: macOS Jobs.