CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

502 Error when Downloading Artifacts

Incident Report for CircleCI

Resolved

We have resolved this incident and artifact downloads have returned to normal.
Posted Nov 12, 2019 - 14:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2019 - 14:05 UTC

Identified

We have scaled up to better handle the high request volume for artifact downloads
Posted Nov 12, 2019 - 14:00 UTC

Update

Our investigation into the root of this issue is ongoing.
Posted Nov 12, 2019 - 13:42 UTC

Update

Our engineers are continuing to investigate this issue.
Posted Nov 12, 2019 - 13:19 UTC

Investigating

We have become aware of errors when downloading job artifacts and are investigating.
Posted Nov 12, 2019 - 12:55 UTC