Self-hosted Runner jobs queuing
Incident Report for CircleCI
Resolved
This incident is now resolved. Thank you for your patience.
Posted Mar 25, 2022 - 14:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2022 - 14:18 UTC
Identified
We are still working at fixing the underlying issue, and assessing the effectiveness of tentative solutions.

We can confirm that Runner jobs created from this point onwards will start successfully.

If any of your Runner jobs are in a queued state, please cancel them and re-run them.
Posted Mar 25, 2022 - 14:18 UTC
Update
We're currently taking steps to confirm and rule out possible causes.

We realize this issue could be disrupting your self-hosted Runner jobs.

Please accept our apologies, and bear with us a little longer.
Posted Mar 25, 2022 - 13:56 UTC
Update
We are continuing to investigate this issue, and involving additional engineering teams in an effort to identify the cause.
Posted Mar 25, 2022 - 13:30 UTC
Update
We are still investigating this issue, and working at identifying the exact cause.

If any of your builds are affected, please contact Support.
Posted Mar 25, 2022 - 13:05 UTC
Update
We are continuing to investigate this issue.
Posted Mar 25, 2022 - 12:47 UTC
Investigating
We are currently investigating an issue causing self-hosted Runner jobs to queue.

At the moment Runner jobs remain in a queued state and are not running.

Please accept our apologies for the disruption.
Posted Mar 25, 2022 - 12:43 UTC
This incident affected: Runner.