GitHub Webhooks and API outage
Incident Report for CircleCI
Resolved
GitHub interactions have returned to normal.
Posted Dec 13, 2019 - 17:58 UTC
Monitoring
We are continuing to monitor GitHub services, which are returning to normal.
Posted Dec 13, 2019 - 17:37 UTC
Update
GitHub is continuing their efforts, which can be tracked on their status page: https://www.githubstatus.com/incidents/4g79klqzy99s. Git services are affected, as well as API calls, which may cause builds to fail.
Posted Dec 13, 2019 - 17:18 UTC
Identified
We are seeing a significant drop in webhooks being sent to us by GitHub. We are also seeing failures when attempting to set commit statuses or GitHub Checks via their API.
Posted Dec 13, 2019 - 16:52 UTC
This incident affected: GitHub API Requests, GitHub Issues, PRs, Dashboard, Projects, and GitHub Notifications.