Some pipelines not triggering due to GitHub API failures

Incident Report for CircleCI

Resolved

It appears that GitHub's `GET /repos/{owner}/{repo}/commits` API is now stable and responsive.
Posted Apr 01, 2026 - 12:23 UTC

Monitoring

GitHub's `GET /repos/{owner}/{repo}/commits` API has appeared to recover. We will continue to monitor this.
Posted Apr 01, 2026 - 12:12 UTC

Identified

We are continuing to see very high error rates from GitHub's `GET /repos/{owner}/{repo}/commits` API.
Posted Apr 01, 2026 - 11:58 UTC

Investigating

Some pipelines may not trigger due to a high rate of API failures on one of GitHub's API endpoints. This includes some manually-triggered pipelines, some OAuth hooks and some scheduled pipelines.
Posted Apr 01, 2026 - 11:55 UTC
This incident affected: Pipelines & Workflows and Upstream Services (GitHub API Requests).