CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

Delays in insights dashboard data

Incident Report for CircleCI

Resolved

We've verified our fix and insights data is refreshing as expected.
Posted May 17, 2025 - 00:57 UTC

Monitoring

We are monitoring our change to catch up on delayed insights data.
Posted May 17, 2025 - 00:40 UTC

Identified

We have identified an issue with delays in insights data.

The cause has been identified and we are working on a solution.
Posted May 17, 2025 - 00:38 UTC
This incident affected: CircleCI Insights.