CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

Issues loading pipelines for a small number of projects

Incident Report for CircleCI

Resolved

This incident has been resolved. A small number of customers who created pipelines between 18:53 UTC and 19:24 UTC that contained config using deprecated config syntax will have seen their build-type jobs fail to start. Customers whose jobs or pipelines failed may rerun them.
Posted Sep 10, 2026 - 20:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2026 - 20:25 UTC

Identified

A small number of customers may see errors or be unable to load the pipelines page for projects with deprecated-config warnings, when using the classic pipelines view. Customers on the new pipelines view are not affected. We’ve identified the cause and deployed a fix.
Posted Sep 10, 2026 - 20:25 UTC
This incident affected: CircleCI UI.