Unable to add Github Authorized User Keys to Projects

Incident Report for CircleCI

Resolved

We have identified a workaround for the issue preventing users from adding User Keys via the "Authorize with GitHub" option.

While the "Authorize with GitHub" button is currently experiencing issues, users can successfully add SSH keys to their projects using our fully supported and documented manual process : https://circleci.com/docs/guides/integration/add-ssh-key/#steps-to-add-additional-ssh-keys

This workaround provides full functionality for adding SSH keys to your projects, effectively resolving the immediate impact. Our engineering team is actively monitoring this issue and will implement a permanent fix to restore the GitHub authorization flow.

Post resolution Update - 17:30 UTC
The GitHub authorization functionality for adding User Keys has been fully restored as of 9:21 UTC. The "Authorize with GitHub" button is now working as expected in project settings.

The manual workaround previously provided is no longer necessary, though it remains a valid alternative method for adding SSH keys.

Thank you for your patience while we resolved this issue.
Posted Nov 05, 2025 - 00:16 UTC

Investigating

We are currently investigating an issue preventing users from adding User Keys to a project when clicking on "Authorize with Github". Adding any other keys such as deploy keys or existing authorized user keys continues to function normally.
Posted Nov 04, 2025 - 23:32 UTC
This incident affected: CircleCI UI.