Usage API data delayed for 5/28

Incident Report for CircleCI

Update

We've identified a small number of duplicate records in the Usage API data. Data is available, but may be inaccurate. We continue to investigate.
Posted May 29, 2026 - 14:57 UTC

Investigating

We are currently investigating this issue.
Posted May 29, 2026 - 14:51 UTC
This incident affects: CircleCI API.