GitHub incident with Pull Requests

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted May 06, 2026 - 21:26 UTC

Update

We are continuing to monitor for any further issues.
Posted May 06, 2026 - 17:54 UTC

Monitoring

GitHub is reporting a major incident for degraded pull request availability. This does not impact running CircleCI builds for newly created pull requests or push events.
Posted May 06, 2026 - 17:54 UTC
This incident affected: Upstream Services (GitHub Pull Requests).