CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

Usage API data delayed

Incident Report for CircleCI

Resolved

The Usage API data is current through yesterday, July 29. The issue is resolved.
Posted Jul 30, 2025 - 15:13 UTC

Update

We are continuing to investigate this issue.
Posted Jul 30, 2025 - 15:10 UTC

Investigating

Usage API data is delayed. Data for yesterday July 29 is not yet available. Data prior to July 29 is still available.
Posted Jul 30, 2025 - 14:49 UTC
This incident affected: CircleCI API.