Investigating intermittent issues with triggering actions on CircleCI due to GitHub API rate limits
Incident Report for CircleCI
Resolved
The issue is resolved. If you have any ongoing issues contact support: https://support.circleci.com/hc/en-us/requests/new?ticket_form_id=855288
Posted Nov 02, 2020 - 13:01 UTC
Monitoring
We are monitoring the solution implemented. If you have any ongoing problems with triggering workflows or triggering actions through the UI please submit a support ticket: https://support.circleci.com/hc/en-us/requests/new?ticket_form_id=855288
Posted Nov 02, 2020 - 12:37 UTC
Update
A solution has been implementing and we are verifying the results. We'll share an update in 20 minutes.
Posted Nov 02, 2020 - 12:11 UTC
Identified
We've identified the issue is related to CircleCI hitting GitHub API rate limits, and we are working to resolve the issue. We'll share an update in 20 minutes.
Posted Nov 02, 2020 - 11:46 UTC
Investigating
We're investigating issues with performing various actions on CircleCI. You may encounter errors when following/un-following projects, re-running workflows, or triggering pipelines.
Posted Nov 02, 2020 - 11:35 UTC
This incident affected: Pipelines & Workflows and CircleCI UI.