Delayed data for Usage API

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 18:48 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 15, 2025 - 17:21 UTC

Identified

We have identified that the Usage API is delayed for yesterday's data. We expect this data to be available in the next few hours and thank you for your patience while we work through this.
Posted Jul 15, 2025 - 17:17 UTC