Insights UI unresponsive

Incident Report for CircleCI

Resolved

This incident has been resolved. The Insights UI is fully operational and all workflow data is accessible.

Thank you for your patience during this incident.
Posted Oct 01, 2025 - 23:04 UTC

Monitoring

The fix has been successfully deployed and verified. The Insights UI is now responsive and workflow metrics and analytics are loading normally.

We are actively monitoring the system to ensure continued stability and confirm the issue is fully resolved. Thank you for your patience while our engineers worked on mitigating this issue.
Posted Oct 01, 2025 - 21:27 UTC

Identified

We have identified the root cause of the unresponsive behavior affecting the Insights UI when accessing workflow metrics and analytics. Our engineering team is currently deploying a fix to resolve this issue.

We will continue to monitor the deployment and provide updates as the fix is rolled out across all systems.

Thank you for your patience.
Posted Oct 01, 2025 - 20:54 UTC

Investigating

We are currently investigating an issue with the Insights UI where workflow-related data is not loading properly. Users may encounter unresponsive behavior when attempting to access workflow metrics and analytics. Other CircleCI services remain operational. We'll provide an update as we work through this issue.
Posted Oct 01, 2025 - 19:44 UTC
This incident affected: CircleCI Insights.