Insights Page Loading Errors and Approval Job Button Issues

Incident Report for CircleCI

Resolved

This incident has been resolved. Both the Insights page and Approval Job buttons are fully operational. System monitoring confirms stable operation

Thank you for your patience while our engineers worked to resolve this issue.
Posted Oct 07, 2025 - 22:57 UTC

Monitoring

We identified an issue that was causing customers to experience errors when loading the Insights page since 21:30 UTC. Additionally, customers were unable to click buttons for Approval Jobs.

The problematic change has been reverted and both issues have been resolved. The Insights page is now loading normally and Approval Job buttons are fully functional.

We are currently monitoring our systems to ensure stability and confirm full resolution of the issue.
Posted Oct 07, 2025 - 22:45 UTC