We continue to see reductions in average wait times for customers requesting Linux, AMD, and Remote Docker resource classes, with maximum delays now reduced to under 3 minutes.
Current Status: - Linux, AMD and Remote Docker jobs: Wait times continue to improve, maximum delays of just under 3 minutes - Docker, Mac, Windows, and Android jobs: Operating normally without delays
Additional capacity continues to come online, and we expect further improvements as our infrastructure scales to meet demand.
Thank you for your patience as we work toward full resolution. Next Update: Within 30 minutes or when normal operation is restored.
Posted Nov 17, 2025 - 19:51 UTC
Update
We are actively adding additional capacity to reduce job start delays for Linux , AMD and Remote Docker resource classes. Current improvements show average wait times are now under one minute for most jobs, with some customers waiting up to 6 minutes for jobs using these resources. . Current Status: - Linux, AMD and Remote Docker jobs: Wait times improving as we expand capacity, delays up to 6 minutes - Docker, Mac, Windows, and Android jobs: Operating normally without delays
Our team is continuing to deploy additional resources to fully eliminate the remaining delays. We expect continued improvement over the next hour as this expanded capacity comes online.
We appreciate your patience as we optimize our infrastructure to meet current demand. Next Update: Within 30 minutes or when normal operation is restored.
Posted Nov 17, 2025 - 18:46 UTC
Identified
We have identified the cause of Machine and Remote Docker delays. We are making changes which we expect to reduce the delays. All jobs will continue to run normally after the delay, and we expect the delay will decrease with time. Thank you for your patience.
Posted Nov 17, 2025 - 17:00 UTC
Investigating
We are investigating Machine and Remote Docker delays. We are working on resolving this as quickly as possible. All jobs will continue to run normally after the delay. Thank you for your patience.