GitLab projects are not building

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 16:32 UTC

Monitoring

On August 21st, GitLab had an incident which meant we did not get refresh tokens, which caused in the invalidation of the credentials we had stored.

As a result, any trigger currently resulting in a Failed to get credential will no longer trigger pipelines in CircleCI. However, since the incident with GitLab has been resolved, simply deleting and re-creating the trigger within CircleCI will result in a new valid credential set and ensure pipelines can trigger moving forward.

Customer Action Required: Delete and re-create the GitLab trigger within your CircleCI project
Posted Aug 25, 2025 - 14:29 UTC

Identified

We've identified the issue and are working on resolving the issue. For some customers you may need to take action before building resumes, we will follow this update with instructions shortly. Thank you for your patience.
Posted Aug 25, 2025 - 11:05 UTC

Investigating

GitLab jobs are currently not building due to a "Failed to get credential" error. We are currently investigating this issue.
Posted Aug 25, 2025 - 09:46 UTC
This incident affected: Pipelines & Workflows and CircleCI API.