Outage impacting web experience and pipelines starting

Incident Report for CircleCI

Resolved

Pipelines and UI access have fully recovered.

Please contact customer support if you have issues running builds.

This incident has been resolved.
Posted Jul 02, 2026 - 16:44 UTC

Update

Pipelines are continuing to run as normal.

We will continue monitoring for recovery.
Posted Jul 02, 2026 - 16:29 UTC

Monitoring

We have identified a source of increased system load which caused failures processing API requests.

We have mitigated the issue and jobs are now running as expected and UI access has recovered.

Some pipelines may have failed or failed to start. Resubmitting should correct these issues.

We are continuing to monitor to ensure recovery.
Posted Jul 02, 2026 - 16:24 UTC

Update

We are investigating an issue that may cause some customers to be redirected to a login page and prevents some pipelines from starting. Thank you for your patience as we continue our mitigation of this issue.
Posted Jul 02, 2026 - 16:07 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2026 - 15:25 UTC
This incident affected: Pipelines & Workflows and CircleCI UI.