This incident has been resolved. Between approximately 16:00 UTC and 17:10 UTC, users may have experienced slow load times on the Pipelines page, errors when viewing pipeline and workflow history, and delays in GitHub commit status checks being delivered.
Jobs and builds were not impacted during this time.
We apologize for the disruption and thank you for your patience.
Posted Feb 20, 2026 - 17:44 UTC
Monitoring
We have deployed a fix to stabilize internal services that were experiencing elevated load. Affected components are recovering and we are closely monitoring to confirm full resolution.
Users may still experience some residual slow load times on the Pipelines page, errors when viewing pipeline and workflow history, and delays in GitHub commit status checks being delivered as systems continue to catch up and stabilize.
Jobs and builds remain unaffected and continue to run as expected.
We thank you for your patience while our engineers worked to stabilize the affected services. We will provide an update within 30 minutes or earlier.
Posted Feb 20, 2026 - 17:31 UTC
Identified
We have deployed a fix to stabilize internal services that were experiencing elevated load since approximately 16:00 UTC. Affected components appear to be recovering and we are closely monitoring the situation.
Users may still experience some slow load times on the Pipelines page, errors when viewing pipeline and workflow history, and delays in GitHub commit status checks being delivered as systems continue to stabilize.
Jobs and builds remain unaffected and continue to run as expected.
We will provide our next update within 30 minutes or sooner if things change. We thank you for your patience while we continue to work to resolve this issue.
Posted Feb 20, 2026 - 17:19 UTC
Update
At approximately 16:00 UTC, we began seeing elevated load on internal data systems that serve read operations across CircleCI. This has resulted in degraded performance on the Pipelines page, difficulty loading historical workflow and pipeline data, and delays in GitHub commit status checks being posted.
Write operations and job execution are unaffected — builds are queuing and running as expected. We are actively working to stabilize affected internal services and restore full read performance across the platform.
We will provide an update within 30 minutes. Thank you for your patience while we work to investigate this issue
Posted Feb 20, 2026 - 16:56 UTC
Investigating
We are currently investigating two issues affecting CircleCI services. Users may experience slow load times on the Pipelines page and errors when attempting to view workflow details. Additionally, GitHub commit status checks may not be updating as expected for some users.
Builds and jobs are continuing to run and are not impacted at this time.
We will provide an update within 30 minutes. Thank you for your patience while we work to investigate this issue
Posted Feb 20, 2026 - 16:25 UTC
This incident affected: CircleCI UI and Notifications & Status Updates.