Some Pipelines are being lost

Incident Report for CircleCI

Resolved

This incident is resolved. Thank you for your patience, and we apologize for any inconvenience.
Posted May 06, 2026 - 20:13 UTC

Monitoring

The rollback was successful. Pipelines are flowing normally again. Monitoring for a bit.
Posted May 06, 2026 - 20:03 UTC

Update

We are continuing to investigate this issue.
Posted May 06, 2026 - 19:43 UTC

Investigating

We are having an issue with some pipelines being lost. We are rolling back the affected service, and will share more information when we have it.
Posted May 06, 2026 - 19:42 UTC
This incident affected: Pipelines & Workflows.