The issue causing intermittent 500 errors with our API has now been resolved. We appreciate your patience and understanding as we worked through this incident. Please reach out to our support team for any further questions or if you experience any further issues.
Posted Jul 31, 2024 - 19:23 UTC
Monitoring
We have implemented a fix for the intermittent 500 errors affecting our API and are currently observing signs of recovery. The error rate has significantly decreased, and services should be returning to normal operation. We will continue to monitor the situation closely, we encourage users to resume normal use of the API.
Posted Jul 31, 2024 - 19:03 UTC
Investigating
Our engineers are actively investigating reports of intermittent 500 Server Error responses for calls to the CircleCI API. If you encounter an error, please retry your request. We will provide further updates as more information becomes available