Vendor Billing Issue
Incident Report for CircleCI
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 01:45 UTC
Identified
Beginning on February 6th, 2023, we began receiving reports that customers were experiencing billing issues when attempting to sign-up for services, refill credits, or renew plans. We have opened a ticket with our billing vendor and they have confirmed the issue and are currently working on a fix.

The number of customers affected by this issue appears to be small, but if you are having difficulty signing up or renewing your billing, please reach out via our Support Portal (https://support.circleci.com/hc/en-us) so we ensure your service with CircleCI is uninterrupted.
Posted Mar 01, 2023 - 19:41 UTC