Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2025 - 20:00 UTC
Scheduled
We will be performing scheduled maintenance on our message queue infrastructure to improve system reliability and performance on Friday November 21, 2025 from 20:00 to 22:00 UTC.
During this maintenance window: - Brief delays (up to a minute) may occur when starting new jobs - Job processing may also experience minimal delays during the maintenance period - All running jobs will continue without interruption
What remains fully available: - CircleCI UI and API - All existing configurations and settings - Job execution (with above mentioned delays)
Our engineering team will be actively monitoring throughout the maintenance window. Thank you for your patience as we work to improve CircleCI's infrastructure.
Posted Nov 19, 2025 - 17:27 UTC
This scheduled maintenance affected: Docker Jobs, Machine Jobs, macOS Jobs, Windows Jobs, and Pipelines & Workflows.