Increased 429 responses for API calls

Incident Report for CircleCI

Resolved

Rates of 429 errors are back within normal ranges.
This issue has now been resolved.
Posted Jun 30, 2025 - 15:54 UTC

Monitoring

We have pushed another change which further mitigates the rate limiting.
Customers should be able to use the API as normal now.
We will continue to monitor the rate of 429s for any changes.
Posted Jun 30, 2025 - 15:43 UTC

Update

We have pushed a change that should reduce the frequency of these rate limits.
We are continuing to investigate and will continue work to reduce this impact further.
Posted Jun 30, 2025 - 15:29 UTC

Identified

Following the scheduled maintenance, we are seeing a reduction in rate limits and an increase in 429 errors.
Customers are currently able to make API requests less frequently than expected.
Posted Jun 30, 2025 - 15:11 UTC
This incident affected: CircleCI API.