Issue with Jobs

Incident Report for CircleCI

Resolved

The incident has been resolved. Thank you for your patience. The "infra-fail" should no longer be occurring.
Posted Dec 05, 2025 - 00:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 00:06 UTC

Identified

We are slowly returning to normal. If you had jobs that failed with "infra-fail", those jobs can be rerun. We thank you for your patience while our engineers worked to get our system back to stability.
Posted Dec 04, 2025 - 23:36 UTC

Investigating

We're currently investigating a high number of infra failures. We'll update as soon as we know more details.
Posted Dec 04, 2025 - 22:53 UTC
This incident affected: Docker Jobs, Machine Jobs, macOS Jobs, and Windows Jobs.